Updates to GStreamer and Totem for Slackware 13.0

The updates I did to GLib2 and GTK+2 have allowed me to move to newer versions of GStreamer and the GStreamer plugin packages. This gives access to newer features and bug fixes. One of the main features is gapless audio playback available only in newer versions of GStreamer.

Here is a list of the recent changes:

gst-plugins-gio – Removed. No longer needed as this is now included in the updated gst-plugins-base package.
gst-ffmpeg – Added version 0.10.10. This is required for playback of certain video codecs such as h.264.
gst-plugins-bad – Updated to 0.10.18.
gst-plugins-base – Added to repository, upgrades stock Slackware package to 0.10.28.
gst-plugins-good – Updated to 0.10.21.
gst-plugins-ugly – Updated to 0.10.14.
gst-python – Updated to 0.10.18.
gstreamer – Added to repository, upgrades stock Slackware package to 0.10.28.
totem – Updated to 2.28.5.
totem-pl-parser – Updated to 2.28.2.
libunique – Added as a requirement for newer version of Totem.
gmime – Upgrades the stock Slackware package. Needed for newer version of totem-pl-parser for proper Podcast support.

Apr 21st, 2010 | Posted in Linux, Slackware
Comments are closed.